๐Ÿ’กMenus

A list of all Flying Logic menu commands and their functionality

Application Menu (Mac)

About Flying Logic

Displays version information and credits.

Preferences...

Displays the Preferences dialog. See Preferences.

Quit Flying Logic

Quits Flying Logic.

๐Ÿ†• NEW IN 4.0

Unsaved work will be auto-saved and reopened the next time Flying Logic is started.

File Menu

New Document

Creates a new, blank document.

New Document From Selection

Creates a new document containing copies of any elements that were selected in the current document.

Open...

Opens an existing document. New documents can also be opened by dragging a Flying Logic document to the application icon (Windows: in Windows Explorer, Mac: in the Finder or Dock, Linux: see your window manager documentation.)

Template files can also be opened, which open as new Untitled documents containing the contents of the template.

Existing exported domain files can also be opened, which causes a new, blank document to be created with the domain automatically imported.

Open Examples...

Allows browsing and opening of a variety of provided example documents. Example documents open as new, untitled documents so you can modify them and save them elsewhere.

Open Recent

Select a name from the submenu to re-open a recently open document.

Close Tab

Closes the current document tab. The user is prompted to save any unsaved changes. If only one document is open in a window, this closes the document and window.

Close Window

Closes the current document window. If multiple documents are open in a window, the application attempts to close them all. The user is prompted to save any unsaved changes.

Save

Saves the current document. If the document has not been saved before, the user is prompted for a file name and folder to save to.

Save As...

Saves the current document in a new location and/or with a new name.

Save as Template...

Saves a copy of the current document in a new location with a new name, and changes its filename suffix to .xlogict. When a template file is opened, it opens as a new, Untitled document, but starts with all the content that was saved with the template.

Import Submenu

Import Diagram from CSV...

Imports a diagram from a simple CSV (comma-separated values) text document. For the format of this document, see the Flying Logic Scripting Guide.

Import from MS Project...

Imports a diagram from an MS Project document in either XML or MPX format. The diagram may include extra elements to properly represent features from MS Project. See the section Notes on MS Project Import and Export in Project Management.

Import via Script Submenu

Open Script...

Executes the selected script as an importer of the current document.

For convenience, the submenu also remembers the last four scripts run this way.

Export Submenu

Export of diagrams to PDF, PNG and JPEG support a โ€œSave Inkโ€ option identical to that available when printing: group backgrounds are not shaded.

Export Diagram as PDF...

Creates a PDF file with the diagram of the current document. The document is formatted as a single page large enough to contain the entire diagram.

Export Diagram as JPEG...

Creates a JPEG file with the diagram of the current document. The document is formatted as a single image large enough to contain the entire diagram.

Export Diagram as PNG...

Creates a PNG file with the diagram of the current document. The document is formatted as a single page large enough to contain the entire diagram.

Export Diagram as Graphviz (DOT)...

Creates a file in the DOT graph description language used by the Graphviz open source graph visualization toolkit.

Export Diagram as Scalable Vector Graphics (SVG)...

Creates a Scalable Vector Graphics (SVG) file with the diagram of the current document. The document is formatted as a single page large enough to contain the entire diagram.

Export Outline as OPML...

Creates an OPML file with the diagram of the current document. OPML documents can be directly imported into many popular outliner applications.

Export Annotations as PDF...

Creates a PDF file with only the annotations in the current document. Each annotation includes its annotation number, which can be cross-referenced with the annotation numbers that appear when the View โžก Note Numbers command is turned on.

Export Annotations as Text...

Creates a plain text file with only the annotations in the current document. Each annotation includes its annotation number, which can be cross-referenced with the annotation numbers that appear when the View โžก Note Numbers command is turned on.

Export as MS Project Data Interchange (XML)...

Exports the current document in MS Project Data Interchange format, which is a format based on XML used to exchange Microsoft Project data.

See below for details on the conversion of Flying Logic documents to MS Project documents.

Export as MS Project Exchange (MPX)...

Exports the current document in MPX format. MPX is a native binary format used to exchange Microsoft Project data.

See below for details on the conversion of Flying Logic documents to MS Project documents.

When to use PDF?

PDF is the most desirable format for publishing and all other applications that do not require a โ€œbitmappedโ€ graphics format (such as JPEG or PNG), as PDF images will scale to any size with no loss of quality. PDF also supports transparency, and will look good when overlaid against backgrounds containing images or textures.

When to use JPEG?

JPEG images are compressed, and may show a slight fuzziness around the edges of lines and text. Also, JPEG images do not support transparency, so programs that overlay images on backgrounds (such as presentation software) will show the JPEG as completely obscuring any background. Exporting the image to PDF or PNG is recommended when transparency is desired.

When to use PNG?

PNG images use a โ€œlosslessโ€ form of compression that does not result in the edge-fuzziness associated with JPEG images. Also, PNG images support transparency, and will look good when overlaid against backgrounds containing images or textures.

Note numbers are fluid

Note numbers change as annotations are added and removed from the document, and should not be relied on to stay the same across document revisions.

Export to MPX is deprecated

Export to MPX is only still provided for users who must use older versions of Microsoft Project that do not import the XML format above. Certain attributes may not be exported correctly when using this command.

Exporting to MS Project

When exporting to MS Project, the following conversion rules apply:

  • All entities are converted to MS Project Tasks of the same effort assigned in the Entity tab of the Element inspector when Project Management is turned on, or 1-day effort if no other effort has been specified. Zero-effort tasks are converted to MS Project milestones. The name of the task is the entityโ€™s title. The Text1 field of the task is set to Entity. The Text2 field of the task is set to the entity class name. The Number1 field of the task is set to the confidence value of the entity.

  • All junctors are converted to MS Project milestones. The name of the task is the name of the junctor operator. The Text1 field of the milestone is set to Junctor. The Number1 field of the task is set to the confidence value of the junctor.

  • All groups are converted to MS Project summary tasks. The name of the summary task is the title of the group. The Text1 field of the summary task is set to Group.

  • All edges are converted to finish-to-start dependencies with no lag.

  • Notes for entities, groups, and junctors become notes on the corresponding tasks. Notes on edges are not preserved, because MS Project does not support notes on task dependencies.

Export via Script Submenu

โžก Open Script...

Executes the selected script as an exporter of the current document.

For convenience, the submenu also remembers the last four scripts run this way.

โžก Print

Prints the current document. The Flying Logic print options dialog appears before the system print dialog, and allows a number of choices for formatting your printed output.

Edit Menu

Undo

Undoes the last action that modified the current document. Virtually every action that modifies Flying Logic documents is undoable, and multiple levels of undo are supported. You can set a preference as to how many levels of undo to support. See Preferences.

Redo

Redoes the last undone action.

Cut

Works as a typical Cut command for text.

For selections of the diagram, marks the selected elements for transfer to another document or another location in the current document. Selected elements are shaded red. See Copy and Paste.

Copy

Works as a typical Copy command for text.

For selections of the diagram, marks the selected elements for copying to another document or another location in the current document. Selected elements are shaded orange. See Copy and Paste.

Paste

Works as a typical Paste command for text.

For selections of the diagram that have previously been selected for Copy, duplicates the copied elements into the currently selected group, or the top level of the diagram if there is no selection.

For selections of the diagram that have previously been selected for Cut, moves the cut elements into the currently selected group, or the top level of the diagram if there is no selection.

See Copy and Paste.

Delete

Deletes the current selection.

Select All

Selects all visible elements in the diagram. Does not select, for example, elements within collapsed groups or elements outside any currently hoisted group.

Deselect

Deselects all currently selected elements.

Select Successors

๐Ÿ†• NEW IN 4.0

For each edge, entity, or junctor in the current selection, add to the selection each directly succeeding element.

Select All Successors

For each edge, entity, or junctor in the current selection, add to the selection every succeeding element. Useful for determining which elements can be affected โ€œdownstreamโ€ of one or more selected elements.

Select Predecessors

๐Ÿ†• NEW IN 4.0

For each edge, entity, or junctor in the current selection, add to the selection each directly preceding element.

Select All Predecessors

For each edge, entity, or junctor in the current selection, add to the selection every preceding element. Useful for determining which elements can be affected โ€œupstreamโ€ of one or more selected elements.

Select Head Entity

Selects the entity at the head of the currently selected edge. Useful for navigating diagrams with long edges.

Select Tail Entity

Selects the entity at the tail of the currently selected edge. Useful for navigating diagrams with long edges.

Select Paths Between Entities

๐Ÿ†• NEW IN 4.0

Starting with two entities selected, find and select all the paths that connect them.

Reverse Selected Edges

Reverses the currently selected edges. See Reversing Edges.

Swap Selected Forward and Back Edges

Exchanges the positions of a single selected forward and back edge pair. See Swapping Forward and Back Edges.

Swap Selected Elements

Exchanges the positions of any two selected elements of the same kind. See Swapping Elements.

Preferences...

Displays the Preferences dialog. (Windows and Linux only. Preferences is located in the Flying Logic menu on the Mac.)

Find...

Displays the Find dialog. This dialog can also be displayed by clicking the Find button in the toolbar.

Run Script Submenu

Open Script...

Executes the selected general purpose script.

For convenience, the submenu also remembers the last four scripts run this way.

Show Console

Displays the scripting system console. Messages output by running scripts will appear in this window.

Entity Menu

New Entity

Creates a new entity of the class selected in the Domain Inspector. See Working With Entities.

Insert Entity

Creates a new entity of the class selected in the Domain Inspector and inserts it along the currently selected edge. See Working With Entities.

Add Entity as Successor

When turned on, newly created entities will be automatically added as successors to a currently selected entity. When turned off, the new entities will be added as a predecessor. See Working With Entities.

New Entities from List on Clipboard

If you have placed text on the clipboard in the format of a list of entity titles, you can select the item to create new entries each with titled from the list and of the class selected in the Domain Inspector.

Reset Confidence

Resets all confidence values in the entire document to 50%. Useful for restarting demonstrations where all confidence values are expected to begin at 50%.

Renumber Entity IDs

Assigns a new Entity ID to all entities in the order they appear in the flow of the document. This is the only command that can change the Entity IDs in the document. See Annotation Numbers and Entity IDs.

Redact Selection

Changes all title and annotation text in the selected elements to Xโ€™s. This can be useful to remove sensitive information from a document before passing it to other parties for review.

Redact All

Changes all title and annotation text in the current document to Xโ€™s. If you need to pass a copy of a document to the Flying Logic developers so we can see how a particular layout behaves, you can use this command to remove all sensitive information from the document first.

Manage Custom Symbols...

Displays the Manage Custom Symbols dialog, which allows you to review, add, or delete custom symbols from the document. See Managing Custom Symbols.

Redaction Modifies the Document

Redaction doesn't simply hide the redacted data in the document, it actually replaces it. Make sure to save an un-redacted version of the document for your own use.

Group Menu

New Group

Creates a new group that encloses the currently selected elements. See Creating Groups.

Collapse Selected Groups

Collapse every selected group, but not any groups they themselves enclose. See Collapsing and Expanding Groups.

Deep-Collapse Selected Groups

Collapse every selected group, including any groups they themselves enclose. See Collapsing and Expanding Groups.

Expand Selected Groups

Expand every selected group, but not any groups they themselves enclose. See Collapsing and Expanding Groups.

Deep-Expand Selected Groups

Expand every selected group, including any groups they themselves enclose. See Collapsing and Expanding Groups.

Group Color

Changes the color of the selected groups to the choice from the submenu. See Group Colors.

Hoist Selected Group

Temporarily hides all document elements outside of the currently selected group. See Hoisting.

Unhoist One Level

Unhides all document elements in the group enclosing the currently hoisted group. See Hoisting.

Unhoist to Top

Unhides all document elements previously hidden by the other hoist commands. See Hoisting.

View Menu

Switch to Chart View / Switch to Graph View

Changes the view of the document window from Graph to Chart and back. See Chart View.

Confidence

Displays or hides the Confidence Spinners. See Confidence Spinners.

Edge Weights

Displays or hides the Edge Weights. See Edge Weights.

Edge Annotations

When turned on, every edge in the diagram will display a yellow box containing the text of the edge annotation instead of the small yellow bullet. Turning this option on supersedes the per-edge display of edge annotations. When turned on, even edges that have no annotation text will display a small yellow empty box where new text can be entered. When turned off, only edges that have the per-edge display of their annotation will display the boxโ€” others edges with annotations will display the yellow bullet. See Annotations.

Annotation Numbers

Displays or hides the Annotation Numbers. See Annotation Numbers and Entity IDs.

Entity IDs

Displays or hides the Entity IDs. See Annotation Numbers and Entity IDs.

Incremental Layout

Turns on or off incremental layout mode. See Incremental Layout.

Project Management

Displays or hides project management attributes throughout the document. See Project Management.

Element Text Attributes...

Displays the Element Text Attributes dialog. See Element Text Attributes.

Reveal Selection

Scrolls the currently-selected elements of the diagram into view, if they are not already visible.

Zoom to Fit

Adjusts the magnification to display the entire diagram.

Full Size

Adjusts the magnification to display the diagram elements at their full size.

Zoom In

Adjusts the magnification to display the diagram elements at their next largest size.

Zoom Out

Adjusts the magnification to display the diagram elements at their next smallest size.

Zoom X%

Adjusts the magnification to display the diagram elements at X% of their normal size.

Domain Menu

New Domain

Creates a new domain in the Domain Inspector. See Creating A Custom Class.

Duplicate Domain

Duplicates the currently-selected domain in the Domain Inspector.

Delete Domain

Deletes the currently selected domain, including all classes within the domain. All entities assigned to deleted classes are reassigned to the Generic class.

New Class

Creates a new custom class within the selected domain. See Creating A Custom Class.

Duplicate Class

Duplicates the currently-selected class in the Domain Inspector.

Delete Class

Deletes the currently selected class. All entities assigned to the deleted class are reassigned to the Generic class.

Import Domain

Prompts the user for a domain file to import, then adds the domain and its classes to the current document. See Exporting and Importing Domains. A shortcut to create a new document with a domain pre-imported is to simply open the exported domain file using the FileOpen command or double-click the exported domain file in your desktop environment.

Export Selected Domain

Prompts the user for the name and location of a domain file to save, and then writes the domain selected in the Domain Inspector, along with all its classes to the file. See Exporting and Importing Domains.

Save Domains as Defaults

After confirmation, saves the currently visible domains as the default set of visible domains for any newly created documents. Also allows restoring the default set of visible domains.

Domain Visibility

Enables any of the built-in domains to be hidden (or re-shown).

Format Menu

Font

Contains formatting options for fonts within annotation text. See Styled Text, Hyperlinks, and Browse Lock.

Make Plain Text

Removes all formatting from the selected annotation text. See See Styled Text, Hyperlinks, and Browse Lock.

Edit Hyperlink

Displays the Hyperlink Properties dialog for the currently selected annotation text. See See Styled Text, Hyperlinks, and Browse Lock.

Window Menu

Inspectors

Contains commands and keyboard shortcuts to display or hide each of the inspectors. See The Sidebar and Inspectors.

Hide Sidebar

Hides or displays the sidebar for times when a more presentation-oriented window format is desired.

Hide Toolbar

Hides or displays the toolbar for times when a more presentation-oriented window format is desired.

Toggle Focus Between Sidebar and Canvas

Changes whether the next keystrokes (such as arrow-key navigation) will be received by the sidebar or the canvas.

List of Open Documents

The Window menu also contains a list of currently open documents. The window for an open document may be brought to the front by selecting its name in this menu.

Help Menu

License Status...

This dialog is used for managing your registration information, including your subscription login status license key.

Edit Your Profile...

๐Ÿ†• NEW IN 4.0

When logged in with a subscriber email address, this will open a web page that will let you change your contact or billing information.

Documentation

The items in this submenu open the Flying Logic User Guide (this document), Welcome to Flying Logic, Thinking With Flying Logic or the Flying Logic Scripting Guide in your web browser.

View License Agreement...

Displays a dialog containing the Flying Logic License Agreement.

View Credits...

Displays a dialog containing credits for Flying Logic.

Visit Flying Logic Web Site

Opens FlyingLogic.com in your web browser, where you can find support for Flying Logic as well as an active community of Flying Logic users.

Check for Updates

Uses your Internet connection to determine whether an updated version of Flying Logic is available for download.

Last updated